You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libetpan/files/libetpan-1.0-ldflags.patch

19 lines
694 B

--- configure.ac.orig 2010-04-20 20:29:01.136283062 +0200
+++ configure.ac 2010-04-20 20:29:45.884283632 +0200
@@ -455,11 +455,11 @@
for flag in "pthreads" "pthread"; do
if test "x$checkpthread" = "xyes"; then
AC_MSG_CHECKING([for pthread_create with -$flag])
- OLDFLAGS="$LDFLAGS"
- LDFLAGS="-$flag $LDFLAGS"
- AC_TRY_LINK([], [pthread_create();],
+ OLDLIBS="$LIBS"
+ LIBS="$LIBS -l$flag"
+ AC_TRY_LINK([], [pthread_create();],
[pthflag=yes; checkpthread=no],
- [pthflag=no; LDFLAGS="$OLDFLAGS"])
+ [pthflag=no; LIBS="$OLDLIBS"])
AC_MSG_RESULT($pthflag)
fi
done