You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libgeotiff/files/libgeotiff-1.2.4-soname.patch

14 lines
667 B

--- configure.in.orig 2008-03-01 14:32:39.000000000 -0800
+++ configure.in 2008-03-01 14:37:27.000000000 -0800
@@ -36,7 +36,9 @@
GEOTIFF_DLL=cyggeotiff-1.dll
GEOTIFF_IMP=libgeotiff.dll.a
LD_SHARED="gcc -shared -Wl,--export-all -Wl,--out-implib=\$(GEOTIFF_IMP)" ;;
- *) GEOTIFF_SO=libgeotiff.${SO_EXT}.$VERSION_MAJOR.$VERSION_MINOR.$VERSION_POINT ;;
+ *) GEOTIFF_SO=libgeotiff.${SO_EXT}.$VERSION_MAJOR.$VERSION_MINOR.$VERSION_POINT
+ GEOTIFF_SONAME=libgeotiff.${SO_EXT}.$VERSION_MAJOR.$VERSION_MINOR
+ LD_SHARED="gcc -shared -Wl,-soname -Wl,$GEOTIFF_SONAME" ;;
esac
fi
AC_SUBST(GEOTIFF_SO,$GEOTIFF_SO)