You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/nibbles/files/nibbles-0.0.4-as-needed.patch

25 lines
458 B

--- a/Makefile
+++ b/Makefile
@@ -1,19 +1,14 @@
-CC = gcc -Wall -g
-
SRCS = player.c main.c loadMap.c cmdline.c ncdrawlib.c scoring.c
OBJS = $(SRCS:.c=.o)
-LIBS = -lncurses
+LDLIBS = $(shell $(PKGCONFIG) --libs ncurses)
INSTALL=/usr/bin/install -c
INSTALL_FOLDER=/usr/games
all: nibbles
-.c.o:
- $(CC) -c $*.c -o $*.o
-
nibbles: $(OBJS)
- $(CC) $(LIBS) $(OBJS) -o $@
+ $(CC) $(LDFLAGS) $(OBJS) $(LDLIBS) -o $@
clean:
rm -f *~ *.o nibbles