You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-te...

21 lines
618 B

--- tinyxml2-1.0.9_p20121123/CMakeLists.txt
+++ tinyxml2-1.0.9_p20121123/CMakeLists.txt
@@ -55,10 +55,13 @@
VERSION "${GENERIC_LIB_VERSION}"
SOVERSION "${GENERIC_LIB_SOVERSION}")
-add_executable(test xmltest.cpp)
-add_dependencies(test tinyxml2)
-add_dependencies(test ${TARGET_DATA_COPY})
-target_link_libraries(test tinyxml2)
+set(BUILD_TEST OFF CACHE BOOL "Set to ON to build tests")
+if(BUILD_TEST)
+ add_executable(test xmltest.cpp)
+ add_dependencies(test tinyxml2)
+ add_dependencies(test ${TARGET_DATA_COPY})
+ target_link_libraries(test tinyxml2)
+endif(BUILD_TEST)
if(BUILD_STATIC_LIBS)