You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/python/files/3.6-disable-nis.patch

22 lines
864 B

--- a/setup.py
+++ b/setup.py
@@ -1332,17 +1332,7 @@ class PyBuildExt(build_ext):
# Jeremy Hylton's rlimit interface
exts.append( Extension('resource', ['resource.c']) )
- # Sun yellow pages. Some systems have the functions in libc.
- if (host_platform not in ['cygwin', 'qnx6'] and
- find_file('rpcsvc/yp_prot.h', inc_dirs, []) is not None):
- if (self.compiler.find_library_file(lib_dirs, 'nsl')):
- libs = ['nsl']
- else:
- libs = []
- exts.append( Extension('nis', ['nismodule.c'],
- libraries = libs) )
- else:
- missing.append('nis')
+ missing.append('nis')
else:
missing.extend(['nis', 'resource', 'termios'])