You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/netpbm/files/netpbm-10.70-system-libs.patch

41 lines
1.0 KiB

when we disable the bundled libs, make sure we don't try to run install in them
--- a/converter/other/jbig/Makefile
+++ b/converter/other/jbig/Makefile
@@ -5,7 +5,7 @@ endif
SUBDIR = converter/other/jbig
VPATH=.:$(SRCDIR)/$(SUBDIR)
-SUBDIRS = libjbig
+SUBDIRS =
include $(BUILDDIR)/config.mk
@@ -35,6 +35,7 @@ SCRIPTS =
ifeq ($(JBIGLIB),$(INTERNAL_JBIGLIB))
JBIGLIB_DEP = $(JBIGLIB)
+ SUBDIRS += libjbig
else
# It's not our internal version; user's on his own to make sure it's built
endif
--- a/converter/other/jpeg2000/Makefile
+++ b/converter/other/jpeg2000/Makefile
@@ -5,7 +5,7 @@ endif
SUBDIR = converter/other/jpeg2000
VPATH=.:$(SRCDIR)/$(SUBDIR)
-SUBDIRS = libjasper
+SUBDIRS =
include $(BUILDDIR)/config.mk
@@ -52,6 +52,7 @@ ifeq ($(JASPERLIB),$(INTERNAL_JASPERLIB)
# MERGE_OBJECTS contains relative paths, so $(INTERNAL_JASPERLIB) had better
# be relative to the current directory.
MERGE_OBJECTS += $(JASPERLIB)
+ SUBDIRS += libjasper
endif
MERGEBINARIES = $(BINARIES)