You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/dropwatch/files/dropwatch-1.4_p20150706-mak...

22 lines
563 B

diff --git a/src/Makefile b/src/Makefile
index 5bc6aaa..4eab2e8 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,14 +1,14 @@
all: dropwatch
CPPFLAGS += -D_GNU_SOURCE
-CFLAGS += -g -Wall -Werror $(shell pkg-config --cflags libnl-3.0)
+CFLAGS += -g -Wall $(shell pkg-config --cflags libnl-3.0)
LDLIBS += -lbfd -lreadline -lnl-3 -lnl-genl-3
OBJFILES := main.o lookup.o\
lookup_bfd.o lookup_kas.o
dropwatch: $(OBJFILES)
- $(LINK.o) $^ $(LOADLIBES) $(LDLIBS) -o $@
+ $(LINK.o) $(CFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
clean:
$(RM) dropwatch *.o