You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/egressor/files/1.0-flags.patch

23 lines
578 B

--- a/client/Makefile
+++ b/client/Makefile
@@ -5,8 +5,8 @@
#----------------------------------------------------------------------
-CC = gcc
-CFLAGS = -O3 -funroll-loops -fomit-frame-pointer -Wall -DMD=5
+CC ?= gcc
+CFLAGS += -Wall -DMD=5
#CFLAGS2 = -O -DMD=5
OBJECTS = egressor.o md5c.o \
@@ -21,7 +21,7 @@
egressor: egressor.o md5c.o
- $(CC) egressor.o $(LIBS) -o ./egressor
+ $(CC) $(CFLAGS) $(LDFLAGS) egressor.o $(LIBS) -o ./egressor
md5c.o: global.h md5.h
$(CC) -c $(CFLAGS) md5c.c