33 lines
1,003 B
Diff
33 lines
1,003 B
Diff
Makefile | 11 +++++------
|
|
1 files changed, 5 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 76e6403..9875e36 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -59,20 +59,19 @@ EXAMPLE=/examples
|
|
HTML=/html
|
|
BIN=/usr/bin
|
|
MAN=/usr/share/man/man1
|
|
-DOC=/usr/share/doc/lisaac
|
|
+DOC=${DOC:=/usr/share/doc/lisaac}
|
|
DESTDIR=
|
|
-CC=gcc
|
|
-CFLAGS=-O2
|
|
+CC ?=gcc
|
|
|
|
all: bin/lisaac.c bin/shorter.c
|
|
@echo "#define LISAAC_DIRECTORY \"$(DESTDIR)$(LIB)\"" > bin/path.h
|
|
- $(CC) $(CFLAGS) bin/lisaac.c -o bin/lisaac
|
|
- $(CC) $(CFLAGS) bin/shorter.c -o bin/shorter
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) bin/lisaac.c -o bin/lisaac
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) bin/shorter.c -o bin/shorter
|
|
|
|
interactive_userland: install_lisaac.c
|
|
@echo - Lisaac compiler installation For Unix / Linux / Windows -
|
|
@echo Please wait...
|
|
- $(CC) $(CFLAGS) install_lisaac.c -o install_lisaac
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) install_lisaac.c -o install_lisaac
|
|
@echo - please run ./install_lisaac to finish the installation
|
|
|
|
install:
|