You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/fotoxx/files/fotoxx-13.01.patch

39 lines
1.5 KiB

diff -r -U1 fotoxx-12.11.orig/Makefile fotoxx-12.11/Makefile
--- fotoxx-12.11.orig/Makefile 2012-11-01 17:20:02.000000000 +0700
+++ fotoxx-12.11/Makefile 2012-11-03 22:19:23.000000000 +0700
@@ -5,4 +5,4 @@
# defaults for parameters that may be pre-defined
-CXXFLAGS ?= -O3 -g -Wall
-LDFLAGS ?= -O3 -g -Wall -rdynamic
+CXXFLAGS += -Wall -Wno-deprecated-declarations
+LDFLAGS += -rdynamic
PREFIX ?= /usr
@@ -14,3 +14,3 @@
LOCALESDIR = $(SHAREDIR)/locales
-DOCDIR = $(PREFIX)/share/doc/fotoxx
+DOCDIR = $(PREFIX)/share/doc/$(PF)
MANDIR = $(PREFIX)/share/man/man1
@@ -18,3 +18,3 @@
-CFLAGS = $(CXXFLAGS) -c `pkg-config --cflags gtk+-3.0`
+CFLAGS = $(CXXFLAGS) -c -DPF=\"$(PF)\" `pkg-config --cflags gtk+-3.0`
LIBS = `pkg-config --libs gtk+-3.0`
@@ -75,5 +75,2 @@
rm -f fotoxx.1.gz
- # menu (desktop) file
- cp -f desktop $(DESTDIR)$(MENUFILE)
- xdg-desktop-menu install $(DESTDIR)$(MENUFILE)
@@ -84,3 +81,2 @@
rm -f $(DESTDIR)$(MANDIR)/fotoxx.1.gz
- xdg-desktop-menu uninstall $(DESTDIR)$(MENUFILE)
rm -f $(DESTDIR)$(MENUFILE)
diff -r -U1 fotoxx-12.11.orig/zfuncs.cc fotoxx-12.11/zfuncs.cc
--- fotoxx-12.11.orig/zfuncs.cc 2012-11-01 17:20:02.000000000 +0700
+++ fotoxx-12.11/zfuncs.cc 2012-11-03 22:21:34.000000000 +0700
@@ -3278,3 +3278,3 @@
strncatv(zlocalesdir,199,work,"/share/",zappname,"/locales",null); // /prefix/share/appname/locales
- strncatv(zdocdir,199,work,"/share/doc/",zappname,null); // /prefix/share/doc/appname
+ strncatv(zdocdir,199,work,"/share/doc/",PF,null); // /prefix/share/doc/$(PF)