You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/performous/files/performous-0.7.0-linguas.patch

16 lines
833 B

--- lang/CMakeLists.txt
+++ lang/CMakeLists.txt
@@ -7,5 +7,11 @@
set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
add_custom_command(OUTPUT ${mofile} COMMAND ${Msgfmt_BIN} -v "${pofile}" -o ${mofile} MAIN_DEPENDENCY ${pofile} COMMENT "Building ${language} locale" VERBATIM)
add_custom_target(locale_${language} ALL DEPENDS ${mofile}) # Make sure the mofiles are always built
- install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
endforeach(language)
+foreach(language $ENV{LINGUAS})
+ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
+ if (EXISTS ${pofile})
+ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
+ install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
+ endif()
+endforeach(language)