You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libaio/files/libaio-0.3.107-ar-ranlib.patch

18 lines
398 B

--- a/src/Makefile
+++ b/src/Makefile
@@ -42,10 +42,12 @@
$(CC) $(L_CFLAGS) -c -o $@ $<
+AR ?= ar
+RANLIB ?= ranlib
libaio.a: $(libaio_objs)
rm -f libaio.a
- ar r libaio.a $^
- ranlib libaio.a
+ $(AR) r libaio.a $^
+ $(RANLIB) libaio.a
$(libname): $(libaio_sobjs) libaio.map
$(CC) $(SO_CFLAGS) -Wl,--version-script=libaio.map -Wl,-soname,$(soname) -o $@ $(libaio_sobjs) $(LINK_FLAGS)