You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/maloc/files/0.2.1-mpi.patch

25 lines
653 B

diff --git a/configure.ac b/configure.ac
index ab7726e..0208780 100644
--- a/configure.ac
+++ b/configure.ac
@@ -381,12 +381,14 @@ AC_SUBST(rl_inc)
dnl # ----------------------
dnl # HANDLE THE MPI LIBRARY
dnl # ----------------------
+mpi_use="";
AC_MSG_CHECKING([whether you want MPI])
-AC_ARG_ENABLE(mpi,
- [ --enable-mpi enable MPI layer [[default=no]]],
- [ mpi_use="yes" ],
- [ mpi_use="" ]
-)
+AC_ARG_ENABLE([mpi],
+ AS_HELP_STRING([--enable-mpi enable MPI layer [[default=no]]]))
+
+AS_IF([test "x$enable_mpi" = "xyes"], [
+ mpi_use="yes"
+])
mpi_lib="";
mpi_inc="";
if test -z "${mpi_use}"; then