You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/aqemu/files/aqemu-0.9.2-qtbindir.patch

16 lines
514 B

Ensure the Qt 5 version of rcc is used instead of whatever is in $PATH.
Gentoo-bug: 589332
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -285,7 +285,7 @@
SET( _out ${CMAKE_CURRENT_SOURCE_DIR}/${_basename}.rcc )
- ADD_CUSTOM_COMMAND( OUTPUT ${_out} COMMAND rcc ARGS ${_in} -binary -o ${_out} DEPENDS ${_in} )
+ ADD_CUSTOM_COMMAND( OUTPUT ${_out} COMMAND ${Qt5Core_RCC_EXECUTABLE} ARGS ${_in} -binary -o ${_out} DEPENDS ${_in} )
SET( ${_sources} ${${_sources}} ${_out} )
ENDFOREACH( curFile )