You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/valgrind/files/valgrind-3.7.0-non-exec-sta...

139 lines
5.5 KiB

diff -Naur valgrind-3.7.0.orig//coregrind/Makefile.am valgrind-3.7.0/coregrind/Makefile.am
--- valgrind-3.7.0.orig//coregrind/Makefile.am 2011-11-10 20:02:47.000000000 -0500
+++ valgrind-3.7.0/coregrind/Makefile.am 2011-11-10 20:03:00.000000000 -0500
@@ -292,14 +292,6 @@
m_demangle/demangle.c \
m_demangle/dyn-string.c \
m_demangle/safe-ctype.c \
- m_dispatch/dispatch-x86-linux.S \
- m_dispatch/dispatch-amd64-linux.S \
- m_dispatch/dispatch-ppc32-linux.S \
- m_dispatch/dispatch-ppc64-linux.S \
- m_dispatch/dispatch-arm-linux.S \
- m_dispatch/dispatch-s390x-linux.S \
- m_dispatch/dispatch-x86-darwin.S \
- m_dispatch/dispatch-amd64-darwin.S \
m_gdbserver/m_gdbserver.c \
m_gdbserver/inferiors.c \
m_gdbserver/m_gdbserver.c \
@@ -322,8 +314,6 @@
m_initimg/initimg-pathscan.c \
m_mach/mach_basics.c \
m_mach/mach_msg.c \
- m_mach/mach_traps-x86-darwin.S \
- m_mach/mach_traps-amd64-darwin.S \
m_replacemalloc/replacemalloc_core.c \
m_scheduler/scheduler.c \
m_scheduler/sema.c \
@@ -335,14 +325,6 @@
m_sigframe/sigframe-s390x-linux.c \
m_sigframe/sigframe-x86-darwin.c \
m_sigframe/sigframe-amd64-darwin.c \
- m_syswrap/syscall-x86-linux.S \
- m_syswrap/syscall-amd64-linux.S \
- m_syswrap/syscall-ppc32-linux.S \
- m_syswrap/syscall-ppc64-linux.S \
- m_syswrap/syscall-arm-linux.S \
- m_syswrap/syscall-s390x-linux.S \
- m_syswrap/syscall-x86-darwin.S \
- m_syswrap/syscall-amd64-darwin.S \
m_syswrap/syswrap-main.c \
m_syswrap/syswrap-generic.c \
m_syswrap/syswrap-linux.c \
@@ -361,6 +343,24 @@
m_ume/main.c \
m_ume/script.c
+COREGRIND_SOURCES_COMMON += \
+ m_dispatch/dispatch-@VGCONF_ARCH_PRI@-@VGCONF_OS@.S \
+ m_syswrap/syscall-@VGCONF_ARCH_PRI@-@VGCONF_OS@.S
+
+if VGCONF_HAVE_PLATFORM_SEC
+COREGRIND_SOURCES_COMMON += \
+ m_dispatch/dispatch-@VGCONF_ARCH_SEC@-@VGCONF_OS@.S \
+ m_syswrap/syscall-@VGCONF_ARCH_SEC@-@VGCONF_OS@.S
+endif
+
+if VGCONF_OS_IS_DARWIN
+COREGRIND_SOURCES_COMMON += \
+ m_start-@VGCONF_ARCH_PRI@-darwin.S \
+ m_start-@VGCONF_ARCH_SEC@-darwin.S \
+ m_mach/mach_traps-@VGCONF_ARCH_PRI@-darwin.S \
+ m_mach/mach_traps-@VGCONF_ARCH_SEC@-darwin.S
+endif
+
libcoregrind_@VGCONF_ARCH_PRI@_@VGCONF_OS@_a_SOURCES = \
$(COREGRIND_SOURCES_COMMON)
nodist_libcoregrind_@VGCONF_ARCH_PRI@_@VGCONF_OS@_a_SOURCES = \
diff -Naur valgrind-3.7.0.orig//coregrind/m_dispatch/dispatch-amd64-linux.S valgrind-3.7.0/coregrind/m_dispatch/dispatch-amd64-linux.S
--- valgrind-3.7.0.orig//coregrind/m_dispatch/dispatch-amd64-linux.S 2011-10-26 17:24:42.000000000 -0400
+++ valgrind-3.7.0/coregrind/m_dispatch/dispatch-amd64-linux.S 2011-11-10 20:07:40.000000000 -0500
@@ -349,11 +349,11 @@
ret
.size VG_(run_a_noredir_translation), .-VG_(run_a_noredir_translation)
+#endif // defined(VGP_amd64_linux)
+
/* Let the linker know we don't need an executable stack */
.section .note.GNU-stack,"",@progbits
-#endif // defined(VGP_amd64_linux)
-
/*--------------------------------------------------------------------*/
/*--- end ---*/
/*--------------------------------------------------------------------*/
diff -Naur valgrind-3.7.0.orig//coregrind/m_dispatch/dispatch-x86-linux.S valgrind-3.7.0/coregrind/m_dispatch/dispatch-x86-linux.S
--- valgrind-3.7.0.orig//coregrind/m_dispatch/dispatch-x86-linux.S 2011-10-26 17:24:42.000000000 -0400
+++ valgrind-3.7.0/coregrind/m_dispatch/dispatch-x86-linux.S 2011-11-10 20:04:07.000000000 -0500
@@ -320,12 +320,11 @@
ret
.size VG_(run_a_noredir_translation), .-VG_(run_a_noredir_translation)
-
+#endif // defined(VGP_x86_linux)
+
/* Let the linker know we don't need an executable stack */
.section .note.GNU-stack,"",@progbits
-#endif // defined(VGP_x86_linux)
-
/*--------------------------------------------------------------------*/
/*--- end ---*/
/*--------------------------------------------------------------------*/
diff -Naur valgrind-3.7.0.orig//coregrind/m_syswrap/syscall-amd64-linux.S valgrind-3.7.0/coregrind/m_syswrap/syscall-amd64-linux.S
--- valgrind-3.7.0.orig//coregrind/m_syswrap/syscall-amd64-linux.S 2011-11-10 20:02:47.000000000 -0500
+++ valgrind-3.7.0/coregrind/m_syswrap/syscall-amd64-linux.S 2011-11-10 20:03:00.000000000 -0500
@@ -205,11 +205,11 @@
ML_(blksys_finished): .quad 5b
.previous
+#endif // defined(VGP_amd64_linux)
+
/* Let the linker know we don't need an executable stack */
.section .note.GNU-stack,"",@progbits
-#endif // defined(VGP_amd64_linux)
-
/*--------------------------------------------------------------------*/
/*--- end ---*/
/*--------------------------------------------------------------------*/
diff -Naur valgrind-3.7.0.orig//coregrind/m_syswrap/syscall-x86-linux.S valgrind-3.7.0/coregrind/m_syswrap/syscall-x86-linux.S
--- valgrind-3.7.0.orig//coregrind/m_syswrap/syscall-x86-linux.S 2011-11-10 20:02:47.000000000 -0500
+++ valgrind-3.7.0/coregrind/m_syswrap/syscall-x86-linux.S 2011-11-10 20:03:00.000000000 -0500
@@ -164,12 +164,12 @@
ML_(blksys_committed): .long 4b
ML_(blksys_finished): .long 5b
.previous
-
-/* Let the linker know we don't need an executable stack */
-.section .note.GNU-stack,"",@progbits
#endif // defined(VGP_x86_linux)
+/* Let the linker know we don't need an executable stack */
+.section .note.GNU-stack,"",@progbits
+
/*--------------------------------------------------------------------*/
/*--- end ---*/
/*--------------------------------------------------------------------*/