You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pillow/files/pillow-2.0.0-libm_linking.p...

21 lines
598 B

--- setup.py
+++ setup.py
@@ -197,7 +197,7 @@
for file in _LIB_IMAGING:
files.append(os.path.join("libImaging", file + ".c"))
- libs = []
+ libs = ["m"]
defs = []
if feature.jpeg:
libs.append(feature.jpeg)
@@ -249,7 +249,7 @@
libraries=[feature.tcl, feature.tk]))
if os.path.isfile("_imagingmath.c"):
- exts.append(Extension("_imagingmath", ["_imagingmath.c"]))
+ exts.append(Extension("_imagingmath", ["_imagingmath.c"], libraries=["m"]))
self.extensions[:] = exts