You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pychecker/files/pychecker-0.8.19-create_scr...

14 lines
460 B

--- setup.py
+++ setup.py
@@ -221,7 +221,9 @@
script_str = "%s %s %%*\n" % (sys.executable, checker_path)
else:
script_str = '#! /bin/sh\n\n%s %s "$@"\n' % (sys.executable, checker_path)
- open(script_path, "w").write(script_str)
+ script = open(script_path, "w")
+ script.write(script_str)
+ script.close()
except Exception, e:
print "ERROR: Unable to create %s: %s" % (script_path, e)
raise e