56 lines
2.3 KiB
Diff
56 lines
2.3 KiB
Diff
From 61ef1a71e312f846b08ec4307c449f03907610a6 Mon Sep 17 00:00:00 2001
|
|
From: Jaco Kroon <jaco@uls.co.za>
|
|
Date: Wed, 23 Dec 2020 19:41:10 +0200
|
|
Subject: [PATCH] pbx_lua: Add LUA_VERSION environment variable to
|
|
./configure.
|
|
|
|
On Gentoo it's possible to have multiple lua versions installed, all
|
|
with a path of /usr, so it's not possible to use the current --with-lua
|
|
option to determisticly pin to a specific version as is required by the
|
|
Gentoo PMS standards.
|
|
|
|
This environment variable allows to lock to specific versions,
|
|
unversioned check will be skipped if this variable is supplied.
|
|
|
|
Change-Id: I8c403eda05df25ee0193960262ce849c7d2fd088
|
|
Signed-off-by: Jaco Kroon <jaco@uls.co.za>
|
|
---
|
|
configure | 7 ++++++-
|
|
configure.ac | 7 +++++--
|
|
2 files changed, 11 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 64a0a5ace5..b380759b2b 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -511,6 +511,7 @@ AST_EXT_LIB_SETUP([LIBXML2], [LibXML2], [libxml2])
|
|
AST_EXT_LIB_SETUP([LIBXSLT], [LibXSLT], [libxslt])
|
|
AST_EXT_LIB_SETUP_OPTIONAL([LIBXSLT_CLEANUP], [LibXSLT Library Cleanup Function], [LIBXSLT], [libxslt])
|
|
AST_EXT_LIB_SETUP([LUA], [Lua], [lua])
|
|
+AC_ARG_VAR([LUA_VERSION],[A space separated list of target lua versions to test.])
|
|
AST_EXT_LIB_SETUP([MISDN], [mISDN user], [misdn])
|
|
AST_EXT_LIB_SETUP([MYSQLCLIENT], [MySQL client], [mysqlclient])
|
|
AST_EXT_LIB_SETUP([NBS], [Network Broadcast Sound], [nbs])
|
|
@@ -2559,7 +2560,7 @@ if test -z "$__opus_include" -o x"$__opus_include" = x" " ; then
|
|
fi
|
|
AST_EXT_LIB_CHECK([OPUSFILE], [opusfile], [op_open_callbacks], [opus/opusfile.h], [], [$__opus_include])
|
|
|
|
-for ver in 5.4 5.3 5.2 5.1; do
|
|
+for ver in ${LUA_VERSION:-5.4 5.3 5.2 5.1}; do
|
|
AST_EXT_LIB_CHECK([LUA], lua${ver}, [luaL_newstate], lua${ver}/lua.h, [-lm])
|
|
if test "x${PBX_LUA}" = "x1" ; then
|
|
if test x"${LUA_DIR}" = x; then
|
|
@@ -2572,7 +2573,9 @@ for ver in 5.4 5.3 5.2 5.1; do
|
|
done
|
|
|
|
# Some distributions (like openSUSE and NetBSD) remove the 5.x suffix.
|
|
-AST_EXT_LIB_CHECK([LUA], [lua], [luaL_newstate], [lua.h], [-lm])
|
|
+if test "x${LUA_VERSION}" = "x"; then
|
|
+ AST_EXT_LIB_CHECK([LUA], [lua], [luaL_newstate], [lua.h], [-lm])
|
|
+fi
|
|
|
|
# Accept either RADIUS client library, their APIs are fully compatible,
|
|
# just different header filenames and different SONAMEs
|
|
--
|
|
2.26.2
|
|
|