You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/paho-mqtt/files/paho-mqtt-1.5.0-strip-test-...

32 lines
801 B

# Remove Pylama from test dependencies.
diff --git a/setup.cfg b/setup.cfg
index 84551cd..73bd714 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,9 +1,6 @@
[aliases]
test=pytest
[tool:pytest]
-addopts=-r xs --pylama
+addopts=-r xs
strict=True
testpaths=tests src
-[pylama]
-linters=pyflakes
-skip=tests/*
diff --git a/setup.py b/setup.py
index 8441de1..2878352 100644
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,7 @@ with open('README.rst', 'rb') as readme_file:
readme = readme_file.read().decode('utf-8')
requirements = []
-test_requirements = ['pytest', 'pylama', 'six']
+test_requirements = ['pytest', 'six']
needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv)
setup_requirements = ['pytest-runner'] if needs_pytest else []
extra_requirements = {'proxy': ['PySocks']}
--