You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-admin/apache-tools/files/apache-tools-2.2.20-Makefil...

42 lines
1.5 KiB

=== modified file 'support/Makefile.in'
--- a/support/Makefile.in
+++ b/support/Makefile.in
@@ -1,9 +1,10 @@
DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
+ logresolve.pl phf_abuse_log.cgi split-logfile
CLEAN_TARGETS = suexec
-PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm $(NONPORTABLE_SUPPORT)
+PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm \
+ $(NONPORTABLE_SUPPORT) log_server_status split-logfile dbmmanage
TARGETS = $(PROGRAMS)
PROGRAM_LDADD = $(UTIL_LDFLAGS) $(PROGRAM_DEPENDENCIES) $(EXTRA_LIBS) $(AP_LIBS)
@@ -12,22 +13,13 @@
include $(top_builddir)/build/rules.mk
install:
- @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
@test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
- @for i in apxs apachectl dbmmanage; do \
+ @for i in $(PROGRAMS) ; do \
if test -f "$(builddir)/$$i"; then \
cp -p $$i $(DESTDIR)$(sbindir); \
chmod 755 $(DESTDIR)$(sbindir)/$$i; \
fi ; \
done
- @if test -f "$(builddir)/envvars-std"; then \
- cp -p envvars-std $(DESTDIR)$(sbindir); \
- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
- fi ; \
- fi
htpasswd_OBJECTS = htpasswd.lo
htpasswd: $(htpasswd_OBJECTS)