You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/imaging/files/imaging-1.1.7-missing-math....

21 lines
717 B

--- setup.py.old 2009-07-03 11:34:59.141671252 +0200
+++ setup.py 2009-07-03 11:51:54.415666711 +0200
@@ -281,6 +281,8 @@ class pil_build_ext(build_ext):
if struct.unpack("h", "\0\1")[0] == 1:
defs.append(("WORDS_BIGENDIAN", None))
+ libs.append("m")
+
exts = [(Extension(
"_imaging", files, libraries=libs, define_macros=defs
))]
@@ -332,7 +334,7 @@ class pil_build_ext(build_ext):
))
if os.path.isfile("_imagingmath.c"):
- exts.append(Extension("_imagingmath", ["_imagingmath.c"]))
+ exts.append(Extension("_imagingmath", ["_imagingmath.c"], libraries=["m"]))
self.extensions[:] = exts