You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/wiggle/files/wiggle-1.0-cflags.patch

23 lines
576 B

Respect user CFLAGS and use pkg-config to get ncurses libs.
--- wiggle-1.0/Makefile
+++ wiggle-1.0/Makefile
@@ -3,7 +3,7 @@
#OptDbg=-O3
#OptDbg=-O3 -march=pentium2
OptDbg=-ggdb
-CFLAGS=$(OptDbg) -I. -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
+CFLAGS += -I. -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
# STRIP = -s
INSTALL = /usr/bin/install
@@ -12,7 +12,7 @@
MANDIR = /usr/share/man
MAN1DIR = $(MANDIR)/man1
MAN5DIR = $(MANDIR)/man5
-LDLIBS = -lncurses
+LDLIBS = $(shell pkg-config --libs ncurses)
all: wiggle wiggle.man test