You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/slony1/files/slony1-2.1.2-ldflags.patch

18 lines
467 B

diff -Naur a/makefiles/Makefile.linux b/makefiles/Makefile.linux
--- a/makefiles/Makefile.linux 2012-01-25 14:13:40.000000000 -0500
+++ b/makefiles/Makefile.linux 2012-02-22 06:15:45.652523000 -0500
@@ -12,9 +12,9 @@
endif
%.so: %.o
- $(CC) -shared -o $@ $<
+ $(CC) $(LDFLAGS) -shared -o $@ $<
%.o: %.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $<
-sqlmansect = 7
\ No newline at end of file
+sqlmansect = 7