You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/lxc/files/lxc-2.0.3-bash-completion.p...

32 lines
1.2 KiB

--- lxc-lxc-2.0.1/config/bash/Makefile.am.orig 2016-05-18 20:40:42.238487678 +0000
+++ lxc-lxc-2.0.1/config/bash/Makefile.am 2016-05-18 20:43:02.163497779 +0000
@@ -2,12 +2,12 @@
if ENABLE_BASH
install-bash:
- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
+ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions/
+ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
uninstall-bash:
- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
+ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
+ rmdir $(DESTDIR)$(datarootdir)/bash-completion/completions/ || :
install-data-local: install-bash
uninstall-local: uninstall-bash
--- lxc-lxc-2.0.1/config/bash/lxc.in.orig 2016-05-18 20:40:51.079488316 +0000
+++ lxc-lxc-2.0.1/config/bash/lxc.in 2016-05-18 20:45:03.506506538 +0000
@@ -1,4 +1,3 @@
-_have lxc-start && {
_lxc_names() {
COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
}
@@ -100,4 +99,3 @@
complete -o default -F _lxc_generic_o lxc-copy
complete -o default -F _lxc_generic_o lxc-start-ephemeral
-}