You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/redis/files/redis-5.0.8-ppc-atomic.patch

20 lines
495 B

diff --git a/src/Makefile b/src/Makefile
index 4b2a31c..4ef853b 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -77,6 +77,14 @@ FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
DEBUG=-g -ggdb
+ifneq (,$(filter powerpc ppc,$(uname_M)))
+ FINAL_LIBS+=-latomic
+else
+ifneq (,$(findstring ppc,$(uname_M)))
+ FINAL_LIBS+=-latomic
+endif
+endif
+
# Linux ARM needs -latomic at linking time
ifneq (,$(filter aarch64 armv,$(uname_M)))
FINAL_LIBS+=-latomic