You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-cluster/slurm/files/disable-sview.patch

77 lines
2.4 KiB

--- a/configure.ac 2019-08-13 20:40:08.000000000 +0200
+++ b/configure.ac 2019-08-22 12:02:02.127865098 +0200
@@ -229,42 +229,6 @@
PKG_CHECK_MODULES([CHECK], [check >= 0.9.8], [ac_have_check="yes"], [ac_have_check="no"])
AM_CONDITIONAL(HAVE_CHECK, test "x$ac_have_check" = "xyes")
-#
-# Tests for GTK+
-#
-
-# use the correct libs if running on 64bit
-if test -d "/usr/lib64/pkgconfig"; then
- PKG_CONFIG_PATH="/usr/lib64/pkgconfig/:$PKG_CONFIG_PATH"
-fi
-
-if test -d "/opt/gnome/lib64/pkgconfig"; then
- PKG_CONFIG_PATH="/opt/gnome/lib64/pkgconfig/:$PKG_CONFIG_PATH"
-fi
-
-AM_PATH_GLIB_2_0([2.7.1], [ac_glib_test="yes"], [ac_glib_test="no"], [gthread])
-
-if test ${glib_config_minor_version=0} -ge 32 ; then
- AC_DEFINE([GLIB_NEW_THREADS], 1, [Define to 1 if using glib-2.32.0 or higher])
-fi
-
-AM_PATH_GTK_2_0([2.7.1], [ac_gtk_test="yes"], [ac_gtk_test="no"], [gthread])
-if test ${gtk_config_minor_version=0} -ge 10 ; then
- AC_DEFINE([GTK2_USE_RADIO_SET], 1, [Define to 1 if using gtk+-2.10.0 or higher])
-fi
-
-if test ${gtk_config_minor_version=0} -ge 12 ; then
- AC_DEFINE([GTK2_USE_TOOLTIP], 1, [Define to 1 if using gtk+-2.12.0 or higher])
-fi
-
-if test ${gtk_config_minor_version=0} -ge 14 ; then
- AC_DEFINE([GTK2_USE_GET_FOCUS], 1, [Define to 1 if using gtk+-2.14.0 or higher])
-fi
-
-if test "x$ac_glib_test" != "xyes" -o "x$ac_gtk_test" != "xyes"; then
- AC_MSG_WARN([cannot build sview without gtk library]);
-fi
-
AM_CONDITIONAL(BUILD_SVIEW, [test "x$ac_glib_test" = "xyes"] && [test "x$ac_gtk_test" = "xyes"])
X_AC_CRAY
@@ -447,7 +411,6 @@
src/sshare/Makefile
src/sstat/Makefile
src/strigger/Makefile
- src/sview/Makefile
src/plugins/Makefile
src/plugins/accounting_storage/Makefile
src/plugins/accounting_storage/common/Makefile
diff -Naur slurm-19.05.2.orig/src/Makefile.am slurm-19.05.2/src/Makefile.am
--- slurm-19.05.2.orig/src/Makefile.am 2019-08-13 20:40:08.000000000 +0200
+++ slurm-19.05.2/src/Makefile.am 2019-08-22 12:02:02.127865098 +0200
@@ -25,5 +25,4 @@
srun \
sshare \
sstat \
- strigger \
- sview
+ strigger
diff -Naur slurm-19.05.2.orig/src/Makefile.in slurm-19.05.2/src/Makefile.in
--- slurm-19.05.2.orig/src/Makefile.in 2019-08-13 20:40:08.000000000 +0200
+++ slurm-19.05.2/src/Makefile.in 2019-08-22 12:02:02.127865098 +0200
@@ -495,8 +495,7 @@
srun \
sshare \
sstat \
- strigger \
- sview
+ strigger
all: all-recursive