You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch

22 lines
534 B

diff -ur gst-python-0.10.9.orig/configure.ac gst-python-0.10.9/configure.ac
--- gst-python-0.10.9.orig/configure.ac 2007-11-28 11:33:05.000000000 +0200
+++ gst-python-0.10.9/configure.ac 2007-11-28 18:09:48.000000000 +0200
@@ -363,6 +363,17 @@
AG_GST_VALGRIND_CHECK
+AC_MSG_CHECKING([whether $LD accepts -z,lazy])
+case `$LD -z,lazy -v 2>&1 </dev/null` in
+*GNU* | *'with BFD'*)
+ LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ AC_MSG_RESULT([yes])
+ ;;
+*)
+ AC_MSG_RESULT([no])
+ ;;
+esac
+
AC_OUTPUT([
Makefile
codegen/Makefile