You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-portage/gentoolkit/files/0.3.1-setup.py-print.patch

30 lines
879 B

From 4e06e9f032ed187ce682434955778c3241854e26 Mon Sep 17 00:00:00 2001
From: Mike Gilbert <floppym@gentoo.org>
Date: Sun, 20 Dec 2015 15:19:06 -0500
Subject: [PATCH] Remove useless print() in set_version
This was causing a TypeError in python3.
Bug: https://bugs.gentoo.org/568906
---
setup.py | 3 ---
1 file changed, 3 deletions(-)
diff --git a/setup.py b/setup.py
index b32b7d6..01e4b3e 100755
--- a/setup.py
+++ b/setup.py
@@ -80,9 +80,6 @@ class set_version(core.Command):
with io.open(f[0], 'r', 1, 'utf_8') as s:
for line in s:
newline = re.sub(pattern %f[1], '"%s"' % ver, line, 1)
- if newline != line:
- #log.info("%s: %s" % (f, newline))
- print("%s: %s" % (f[0], newline.encode('utf_8').strip('\n')))
updated_file.append(newline)
with io.open(f[0], 'w', 1, 'utf_8') as s:
s.writelines(updated_file)
--
2.6.4