You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-biology/sim4/files/sim4-20030921-fix-build-sys...

22 lines
491 B

Fix build system to honour user flags.
--- a/Makefile
+++ b/Makefile
@@ -1,13 +1,11 @@
-
# For better performance, replace ``-O'' with whatever
# the best optimization flag is for your computer.
# For Sun's compilers under Solaris, ``-fast'' works well.
# For gcc, ``-O2'' works well.
-CC=cc
-CFLAGS=-O
-LDLIBS=-lm
+CC ?= gcc
+LDLIBS = -lm
sim4:
- $(CC) -o sim4 -I. $(CFLAGS) *.c $(LDLIBS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o sim4 -I. *.c $(LDLIBS)
clean:
rm -f sim4 *.o