You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-misc/boinc/files/7.8-fix_xlocale.patch

43 lines
1.9 KiB

--- a/configure.ac 2017-12-18 17:45:19.829854890 +0100
+++ b/configure.ac 2017-12-18 17:46:13.845853923 +0100
@@ -602,7 +602,7 @@
echo "DEBUG: GLUT_CFLAGS = $GLUT_CFLAGS" >&5
echo "DEBUG: GLUT_LIBS = $GLUT_LIBS" >&5
- AC_CHECK_HEADERS([gl.h glu.h glut.h glaux.h GL/gl.h GL/glu.h GL/glut.h GL/glaux.h OpenGL/gl.h OpenGL/glu.h OpenGL/glut.h OpenGL/glaux.h GLUT/glut.h MesaGL/gl.h MesaGL/glu.h MesaGL/glut.h MesaGL/glaux.h libnotify/notify.h gtk/gtk.h locale.h xlocale.h])
+ AC_CHECK_HEADERS([gl.h glu.h glut.h glaux.h GL/gl.h GL/glu.h GL/glut.h GL/glaux.h OpenGL/gl.h OpenGL/glu.h OpenGL/glut.h OpenGL/glaux.h GLUT/glut.h MesaGL/gl.h MesaGL/glu.h MesaGL/glut.h MesaGL/glaux.h libnotify/notify.h gtk/gtk.h locale.h])
AC_CHECK_LIB([jpeg], [jpeg_start_compress],[have_jpeg=1],[have_jpeg=0])
AC_CHECK_HEADER([jpeglib.h],[have_jpeg=1],[have_jpeg=0])
@@ -986,9 +986,6 @@
#ifdef HAVE_LOCALE_H
#include <locale.h>
#endif
-#ifdef HAVE_XLOCALE_H
-#include <xlocale.h>
-#endif
]])
dnl Checks for typedefs, structures, and compiler characteristics.
--- a/lib/gui_rpc_client.h 2017-12-18 17:47:22.826852688 +0100
+++ b/lib/gui_rpc_client.h 2017-12-18 17:48:42.384851263 +0100
@@ -807,7 +807,6 @@
#elif defined(__APPLE__) && (MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_X_VERSION_10_4)
// uselocale() is not available in OS 10.3.9 so use weak linking
-#include <xlocale.h>
extern int freelocale(locale_t) __attribute__((weak_import));
extern locale_t newlocale(int, __const char *, locale_t) __attribute__((weak_import));
extern locale_t uselocale(locale_t) __attribute__((weak_import));
--- a/clientgui/AsyncRPC.cpp 2017-12-18 17:47:30.727852546 +0100
+++ b/clientgui/AsyncRPC.cpp 2017-12-18 17:48:56.785851005 +0100
@@ -20,7 +20,7 @@
#endif
#if !(defined(_WIN32) || (defined(__WXMAC__) && (MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_X_VERSION_10_4)))
-#include <xlocale.h>
+#include <locale.h>
#endif
#include "stdwx.h"