gentoo-overlay/dev-tcltk/blt/files/blt-2.4z-r4-fix-makefile.patch

23 lines
817 B
Diff

Source: mescalinum
Upstream: N/A
Reason: fix broken $DESTDIR support in library/Makefile
--- library/Makefile.in.orig 2008-10-26 14:30:28.000000000 +0100
+++ library/Makefile.in 2008-10-26 14:31:40.000000000 +0100
@@ -45,7 +45,7 @@ all: pkgIndex
pkgIndex:
rm -f pkgIndex.tcl
- sed -e 's/%VERSION%/$(version)/' $(srcdir)/pkgIndex.tcl.in | \
+ sed -e 's/%VERSION%/$(version)/' $(INSTALL_ROOT)$(srcdir)/pkgIndex.tcl.in | \
sed -e 's/%LIB_PREFIX%/$(lib_prefix)/' | \
sed -e 's;%LIB_DIR%;$(libdir);' > pkgIndex.tcl
@@ -58,7 +58,7 @@ install: mkdirs pkgIndex
for i in $(miscFiles) ; do \
$(INSTALL_DATA) $(srcdir)/$$i $(INSTALL_ROOT)$(scriptdir) ; \
done
- $(INSTALL_DATA) pkgIndex.tcl $(scriptdir)
+ $(INSTALL_DATA) pkgIndex.tcl $(INSTALL_ROOT)$(scriptdir)
mkdirs:
@for i in $(instdirs) ; do \