You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/mail-client/geary/files/geary-0.4.0-unity.patch

32 lines
1.0 KiB

commit 1f875e8a629a54748eb46237fd854359aa5edbc8
Author: hasufell <hasufell@gentoo.org>
Date: Tue Aug 27 01:40:45 2013 +0200
provide option for unity
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66145c9..5d4464c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,7 @@ option(DEBUG "Build for debugging." OFF)
option(ICON_UPDATE "Run gtk-update-icon-cache after the install." ON)
option(DESKTOP_UPDATE "Run update-desktop-database after the install." ON)
option(DESKTOP_VALIDATE "Check generated desktop file for errors during build." ON)
+option(WITH_UNITY "Add unity support." OFF)
if (DEBUG)
message(STATUS "Debug build")
@@ -50,8 +51,10 @@ if (DESKTOP_VALIDATE)
endif ()
find_package(PkgConfig)
-pkg_check_modules(LIBUNITY QUIET unity>=5.12.0)
-pkg_check_modules(LIBMESSAGINGMENU QUIET messaging-menu>=12.10.2)
+if(WITH_UNITY)
+ pkg_check_modules(LIBUNITY QUIET unity>=5.12.0)
+ pkg_check_modules(LIBMESSAGINGMENU QUIET messaging-menu>=12.10.2)
+endif()
# intl
include(Gettext)