You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/isl/files/isl-0.24-nobash.patch

36 lines
1.1 KiB

Fix-by: Matt Whitlock
Bug: https://bugs.gentoo.org/786564
--- a/configure.ac 2020-11-01 13:53:47.000000000 +0000
+++ b/configure.ac 2021-04-28 19:34:28.615119537 +0000
@@ -83,8 +83,8 @@
AM_CONDITIONAL(GMP_FOR_MP, test x$with_int = xgmp)
AM_CONDITIONAL(HAVE_CXX11, test "x$HAVE_CXX11" = "x1")
-AM_CONDITIONAL(SMALL_INT_OPT, test "x$with_int" == "ximath-32")
-AS_IF([test "x$with_int" == "ximath-32"], [
+AM_CONDITIONAL(SMALL_INT_OPT, test "x$with_int" = "ximath-32")
+AS_IF([test "x$with_int" = "ximath-32"], [
AC_DEFINE([USE_SMALL_INT_OPT], [], [Use small integer optimization])
])
--- a/configure 2020-11-01 13:53:55.000000000 +0000
+++ b/configure 2021-04-28 19:34:29.246125644 +0000
@@ -20654,7 +20654,7 @@
HAVE_CXX11_FALSE=
fi
- if test "x$with_int" == "ximath-32"; then
+ if test "x$with_int" = "ximath-32"; then
SMALL_INT_OPT_TRUE=
SMALL_INT_OPT_FALSE='#'
else
@@ -20662,7 +20662,7 @@
SMALL_INT_OPT_FALSE=
fi
-if test "x$with_int" == "ximath-32"; then :
+if test "x$with_int" = "ximath-32"; then :
$as_echo "#define USE_SMALL_INT_OPT /**/" >>confdefs.h