You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/xpaint/files/xpaint-3.1.4-gentoo-shared-...

16 lines
503 B

xpaint was compiling and installing a shared library but it was not using it, linking with the static one instead
This patch attempts to link with libxpaintrw.so instead
So we can pass --disable-static to configure
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,7 +79,7 @@
xpaint_SOURCES = $(BASE_HDRS) $(BASE_SRCS)
-xpaint_LDADD = xpaintrw/.libs/libxpaintrw.a @X_LIBS@ @X_LIBS_EXTRA@
+xpaint_LDADD = -Lxpaintrw/.libs -lxpaintrw @X_LIBS@ @X_LIBS_EXTRA@
docs: INSTALL README TODO ChangeLog
.PHONY: