You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/cheese/files/cheese-3.38.0-buildfix.patch

18 lines
736 B

diff --git a/meson.build b/meson.build
index 7ef4075f..36638472 100644
--- a/meson.build
+++ b/meson.build
@@ -149,11 +149,7 @@ gnome_video_effects_dep = dependency(
# Recommend some runtime GStreamer plugins.
gst_inspect = find_program('gst-inspect-1.0', required: false)
if gst_inspect.found()
- foreach plugin: ['camerabin', 'vp8enc', 'webmmux']
- if run_command(gst_inspect, plugin).returncode() != 0
- warning(plugin + ' was not found. It needs to be installed before Cheese is run')
- endif
- endforeach
+ warning('unable to check for runtime GStreamer plugin dependencies due to Gentoo\'s sandbox: camerabin, vp8enc, webmmux')
else
warning('unable to check for runtime GStreamer plugin dependencies')
endif