You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch

95 lines
3.8 KiB

diff -Naur uuid-1.6.1.orig/Makefile.in uuid-1.6.1/Makefile.in
--- uuid-1.6.1.orig/Makefile.in 2008-03-28 22:02:53.000000000 +0100
+++ uuid-1.6.1/Makefile.in 2008-03-28 22:03:16.000000000 +0100
@@ -62,13 +62,13 @@
PHP = @PHP@
PG_CONFIG = @PG_CONFIG@
-LIB_NAME = libuuid.la
+LIB_NAME = libossp-uuid.la
LIB_OBJS = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_time.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
-DCE_NAME = libuuid_dce.la
+DCE_NAME = libossp-uuid_dce.la
DCE_OBJS = uuid_dce.lo $(LIB_OBJS)
-CXX_NAME = libuuid++.la
+CXX_NAME = libossp-uuid++.la
CXX_OBJS = uuid++.lo $(LIB_OBJS)
PRG_NAME = uuid
@@ -253,7 +253,7 @@
-@if [ ".$(WITH_CXX)" = .yes ]; then \
$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 644 $(CXX_NAME) $(DESTDIR)$(libdir)/; \
fi
- @$(LIBTOOL) --mode=install $(SHTOOL) install -c -s -m 755 uuid $(DESTDIR)$(bindir)/
+ @$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 755 uuid $(DESTDIR)$(bindir)/
$(SHTOOL) install -c -m 644 $(S)/uuid.1 $(DESTDIR)$(mandir)/man1/
-@if [ ".$(WITH_PERL)" = .yes ]; then \
(cd $(S)/perl && $(MAKE) $(MFLAGS) install DESTDIR=$(DESTDIR)); \
diff -Naur uuid-1.6.1.orig/php/config.m4 uuid-1.6.1/php/config.m4
--- uuid-1.6.1.orig/php/config.m4 2008-03-28 22:02:53.000000000 +0100
+++ uuid-1.6.1/php/config.m4 2008-03-28 23:22:54.000000000 +0100
@@ -33,10 +33,10 @@
if test "$PHP_UUID" != "no"; then
PHP_NEW_EXTENSION(uuid, uuid.c, $ext_shared)
AC_DEFINE(HAVE_UUID, 1, [Have OSSP uuid library])
- PHP_ADD_LIBPATH([..], )
- PHP_ADD_LIBRARY([uuid],, UUID_SHARED_LIBADD)
+ PHP_ADD_LIBRARY([ossp-uuid],, UUID_SHARED_LIBADD)
PHP_ADD_INCLUDE([..])
PHP_SUBST(UUID_SHARED_LIBADD)
+ LDFLAGS="$LDFLAGS -L../.libs"
dnl avoid linking conflict with a potentially existing uuid_create(3) in libc
AC_CHECK_FUNC(uuid_create,[
diff -Naur uuid-1.6.1.orig/php/Makefile.local uuid-1.6.1/php/Makefile.local
--- uuid-1.6.1.orig/php/Makefile.local 2008-03-28 22:02:53.000000000 +0100
+++ uuid-1.6.1/php/Makefile.local 2008-03-28 22:10:17.000000000 +0100
@@ -42,7 +42,7 @@
test: build
@version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; \
- $(PHP) -q -d "safe_mode=0" -d "extension_dir=./" uuid.ts $$version
+ $(PHP) -q -d "safe_mode=0" -d "extension_dir=./modules/" uuid.ts $$version
install: build
@version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; extdir="$(EXTDIR)"; \
diff -Naur uuid-1.6.1.orig/php/uuid.ts uuid-1.6.1/php/uuid.ts
--- uuid-1.6.1.orig/php/uuid.ts 2008-03-28 22:02:53.000000000 +0100
+++ uuid-1.6.1/php/uuid.ts 2008-03-28 22:10:37.000000000 +0100
@@ -36,7 +36,7 @@
print "++ loading DSO uuid.so (low-level API)\n";
if (!extension_loaded('uuid')) {
- dl('modules/uuid.so');
+ dl('uuid.so');
}
print "++ loading PHP uuid.php${php_version} (high-level API)\n";
diff -Naur uuid-1.6.1.orig/uuid-config.in uuid-1.6.1/uuid-config.in
--- uuid-1.6.1.orig/uuid-config.in 2008-03-28 22:02:53.000000000 +0100
+++ uuid-1.6.1/uuid-config.in 2008-03-28 22:03:06.000000000 +0100
@@ -121,7 +121,7 @@
output_extra="$output_extra $uuid_ldflags"
;;
--libs)
- output="$output -luuid"
+ output="$output -lossp-uuid"
output_extra="$output_extra $uuid_libs"
;;
* )
diff -Naur uuid-1.6.1.orig/uuid.pc.in uuid-1.6.1/uuid.pc.in
--- uuid-1.6.1.orig/uuid.pc.in 2008-03-28 22:02:53.000000000 +0100
+++ uuid-1.6.1/uuid.pc.in 2008-03-28 22:03:06.000000000 +0100
@@ -36,7 +36,7 @@
Description: Universally Unique Identifier (UUID) Library
Version: @UUID_VERSION_RAW@
URL: http://www.ossp.org/pkg/lib/uuid/
-Cflags: -I${includedir}
-Libs: -L${libdir} -luuid
+Cflags: -I${includedir}/ossp
+Libs: -L${libdir} -lossp-uuid
Libs.private: @LIBS@