You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emacs/bbdb/files/bbdb-3.1.2-no-init.patch

127 lines
4.6 KiB

This file contains invisible Unicode characters!

This file contains invisible Unicode characters that may be processed differently from what appears below. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to reveal hidden characters.

Patch from upstream, backported to bbdb-3.1.2.
From e028f4d8f04c3db663db023cf5a630461cfda2bd Mon Sep 17 00:00:00 2001
From: Roland Winkler <winkler@gnu.org>
Date: Wed, 23 Jul 2014 03:27:09 +0000
Subject: Do not load init file or site file for byte compilation
--- bbdb-3.1.2-orig/lisp/Makefile.am
+++ bbdb-3.1.2/lisp/Makefile.am
@@ -20,6 +20,9 @@
# You should have received a copy of the GNU General Public License
# along with BBDB. If not, see <http://www.gnu.org/licenses/>.
+# --batch implies --no-init-file, yet let's be explicit about what we want
+AM_ELCFLAGS += --no-init-file --no-site-file
+
dist_lisp_LISP = \
bbdb.el \
bbdb-anniv.el \
@@ -70,10 +73,11 @@
@echo " " >> $@;
# Generated autoload-file must have an absolute path,
# $srcdir can be relative.
- $(EMACS) -batch -l autoload \
+ $(EMACS) --batch $(AM_ELCFLAGS) $(ELCFLAGS) \
+ --load autoload \
--eval '(setq generated-autoload-file "'$(abs_builddir)/$@'")' \
--eval '(setq make-backup-files nil)' \
- -f batch-update-autoloads $(srcdir)
+ --funcall batch-update-autoloads $(srcdir)
# Generate bbdb-site.el here as pkgdatadir is only known at "make" time.
# We protect the autoconf variables in the sed regular expressions
--- bbdb-3.1.2-orig/lisp/makefile-temp
+++ bbdb-3.1.2/lisp/makefile-temp
@@ -43,13 +43,16 @@
EMACSOPT =
# The actual Emacs command run in the targets below.
-emacs = LC_ALL=C $(EMACS) --batch --directory=./ $(EMACSOPT)
+# --batch implies --no-init-file, yet let's be explicit about what we want
+emacs = LC_ALL=C $(EMACS) --batch --no-init-file --no-site-file \
+ --directory=./ $(EMACSOPT)
+emacs_compile = $(emacs) --funcall batch-byte-compile
-# If you want to use BBDB with VM this should point to your vm/lisp directory.
-# See also the target all below.
+# VM is not part of GNU Emacs. If you want to use BBDB with VM
+# then the variable VMDIR should point to your vm/lisp directory.
VMDIR =
-VM = -eval '(unless (string-match "$(VMDIR)" "") (push "$(VMDIR)" load-path))'
+VM = -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path))'
.SUFFIXES: .elc .el .tar .Z .gz .uu
@@ -89,51 +92,50 @@
@echo " " >> $@;
# Generated autoload-file must have an absolute path,
# $(srcdir) can be relative.
- $(emacs) -l autoload \
+ $(emacs) --load autoload \
--eval '(setq generated-autoload-file "'`pwd`/$@'")' \
--eval '(setq make-backup-files nil)' \
- -f batch-update-autoloads `pwd`
+ --funcall batch-update-autoloads `pwd`
.el.elc:
- $(emacs) -f batch-byte-compile $<
+ $(emacs_compile) $<
# Not perfect, but better than nothing: If we do not have / do not use
# autotools, we simply copy bbdb-site.el.in to bbdb-site.el.
bbdb-site.el: bbdb-site.el.in
$(CP) $< $@
bbdb-site.elc: bbdb-site.el
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb.elc: bbdb.el bbdb-site.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-com.elc: bbdb-com.el bbdb.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-mua.elc: bbdb-mua.el bbdb-com.elc
- $(emacs) -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path) (load "vm" t t))' \
- -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) -eval '(unless (string= "$(VMDIR)" "") (push "$(VMDIR)" load-path) (load "vm" t t))' \
+ $(@:.elc=.el)
bbdb-rmail.elc: bbdb-rmail.el bbdb-mua.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-gnus.elc: bbdb-gnus.el bbdb-mua.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-mhe.elc: bbdb-mhe.el bbdb-mua.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
-# VM is not part of GNU Emacs
+ $(emacs_compile) $(@:.elc=.el)
bbdb-vm.elc: bbdb-vm.el bbdb-mua.elc
- $(emacs) $(VM) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(VM) $(@:.elc=.el)
bbdb-sc.elc: bbdb-sc.el bbdb-mua.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-print.elc: bbdb-print.el bbdb-com.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-migrate.elc: bbdb-migrate.el bbdb.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-anniv.elc: bbdb-anniv.el bbdb-com.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-ispell.elc: bbdb-ispell.el bbdb.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
bbdb-snarf.elc: bbdb-snarf.el bbdb-com.elc
- $(emacs) -f batch-byte-compile $(@:.elc=.el)
+ $(emacs_compile) $(@:.elc=.el)
install-el: all
$(INSTALL) -d -m 0755 "$(lispdir)/"