You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-games/wfmath/files/wfmath-1.0.2-fix-bashisms.p...

17 lines
592 B

--- a/configure.ac
+++ b/configure.ac
@@ -81,11 +81,11 @@ PKG_CHECK_MODULES(ATLAS_0_6, atlascpp-0.6 >= 0.6.0,
dnl those should already be using Atlas explicitly.
], found_atlas_0_6=no)
-AM_CONDITIONAL(HAVE_ATLAS_0_6, test $found_atlas_0_6 == yes)
+AM_CONDITIONAL(HAVE_ATLAS_0_6, test $found_atlas_0_6 = xyes)
AC_CHECK_HEADERS(sstream strstream, [ found_string_stream=yes break ],
[ found_string_stream=no ])
-if test $found_string_stream == no ; then
+if test $found_string_stream = xno ; then
AC_MSG_ERROR(Couldn't find C++ string <-> stream conversion method.)
fi