You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/hiredis/files/hiredis-2.0.0-system-libs.p...

15 lines
390 B

--- hiredis-2.0.0/setup.py
+++ hiredis-2.0.0/setup.py
@@ -11,9 +11,8 @@
return module.__version__
ext = Extension("hiredis.hiredis",
- sources=sorted(glob.glob("src/*.c") +
- ["vendor/hiredis/%s.c" % src for src in ("alloc", "read", "sds")]),
- include_dirs=["vendor"])
+ sources=sorted(glob.glob("src/*.c")),
+ libraries=["hiredis"])
setup(
name="hiredis",