You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/socketpool/files/socketpool-0.5.2-locale.patch

22 lines
615 B

diff -ur socketpool-0.5.2.orig/setup.py socketpool-0.5.2/setup.py
--- socketpool-0.5.2.orig/setup.py 2012-08-05 12:33:47.000000000 +0800
+++ socketpool-0.5.2/setup.py 2013-02-05 00:22:13.685705089 +0800
@@ -5,7 +5,7 @@
# See the NOTICE for more information.
-import os
+import os, io
from setuptools import setup, find_packages
CLASSIFIERS = [
@@ -22,7 +22,7 @@
# read long description
-with open(os.path.join(os.path.dirname(__file__), 'README.rst')) as f:
+with io.open(os.path.join(os.path.dirname(__file__), 'README.rst'), encoding='utf8') as f:
long_description = f.read()
DATA_FILES = [