You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-util/joystick/files/joystick-1.6.0-build.patch

35 lines
831 B

--- linuxconsoletools-1.6.0/docs/Makefile
+++ linuxconsoletools-1.6.0/docs/Makefile
@@ -20,9 +20,13 @@
# 02110-1301 USA.
MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
+ ffset.1 ffcfstress.1 jscal-store.1 \
jscal-restore.1 evdev-joystick.1
+ifneq ($(USE_SDL),no)
+MANPAGES += ffmvforce.1
+endif
+
PREFIX ?= /usr/local
install:
--- linuxconsoletools-1.6.0/utils/Makefile
+++ linuxconsoletools-1.6.0/utils/Makefile
@@ -27,9 +27,13 @@
CFLAGS ?= -g -O2 -Wall
-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
+PROGRAMS = inputattach jstest jscal fftest ffset \
ffcfstress jscal-restore jscal-store evdev-joystick
+ifneq ($(USE_SDL),no)
+PROGRAMS += ffmvforce
+endif
+
PREFIX ?= /usr/local
compile: $(PROGRAMS)