You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch

16 lines
520 B

--- a/Makefile
+++ b/Makefile
@@ -4,9 +4,11 @@
PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
-LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
+PKG_CONFIG ?= pkg-config
-INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
+LIBS+=-lrt -lpthread $(shell $(PKG_CONFIG) --libs $(PKGS)) -L${SYSROOT}/opt/vc/lib
+
+INCLUDES+=$(shell $(PKG_CONFIG) --cflags $(PKGS)) -I${SYSROOT}/opt/vc/include -I. -Ilinux
DIST ?= omxplayer-dist