You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/subtitleripper/files/subtitleripper-0.3.4-respec...

29 lines
762 B

Index: subtitleripper/Makefile
===================================================================
--- subtitleripper.orig/Makefile
+++ subtitleripper/Makefile
@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
# Target
subtitle2pgm: subtitle2pgm.o spudec.o
@echo "Linking $@"
- @$(CC) $^ -o $@ $(LIBS)
+ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
subtitle2vobsub: subtitle2vobsub.o vobsub.o
@echo "Linking $@"
- @$(CC) $^ -o $@ $(LIBS)
+ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
srttool: srttool.o
@echo "Linking $@"
- @$(CC) -g $^ -o $@ $(LIBS)
+ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
@echo "Linking $@"
- @$(CC) -g $^ -o $@ $(LIBS)
+ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
.PHONY: clean dist rpm
clean: