You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/iproute2/files/iproute2-4.20.0-no-ipv6.patch

39 lines
1.3 KiB

--- iproute2-4.20.0/ip/ipmonitor.c
+++ iproute2-4.20.0/ip/ipmonitor.c
@@ -118,7 +118,6 @@
case RTM_NEWPREFIX:
print_headers(fp, "[PREFIX]", ctrl);
- print_prefix(n, arg);
return 0;
case RTM_NEWRULE:
--- iproute2-4.20.0/ip/iptunnel.c
+++ iproute2-4.20.0/ip/iptunnel.c
@@ -549,13 +549,6 @@
break;
case AF_INET:
break;
- /*
- * This is silly enough but we have no easy way to make it
- * protocol-independent because of unarranged structure between
- * IPv4 and IPv6.
- */
- case AF_INET6:
- return do_ip6tunnel(argc, argv);
default:
fprintf(stderr, "Unsupported protocol family: %d\n", preferred_family);
exit(-1);
--- iproute2-4.20.0/ip/Makefile
+++ iproute2-4.20.0/ip/Makefile
@@ -1,7 +1,7 @@
# SPDX-License-Identifier: GPL-2.0
IPOBJ=ip.o ipaddress.o ipaddrlabel.o iproute.o iprule.o ipnetns.o \
- rtm_map.o iptunnel.o ip6tunnel.o tunnel.o ipneigh.o ipntable.o iplink.o \
- ipmaddr.o ipmonitor.o ipmroute.o ipprefix.o iptuntap.o iptoken.o \
+ rtm_map.o iptunnel.o tunnel.o ipneigh.o ipntable.o iplink.o \
+ ipmaddr.o ipmonitor.o ipmroute.o iptuntap.o iptoken.o \
ipxfrm.o xfrm_state.o xfrm_policy.o xfrm_monitor.o iplink_dummy.o \
iplink_ifb.o iplink_nlmon.o iplink_team.o iplink_vcan.o iplink_vxcan.o \
iplink_vlan.o link_veth.o link_gre.o iplink_can.o iplink_xdp.o \