You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch

20 lines
603 B

http://forum.canardpc.com/threads/110954-PATCH-fix-parallel-build-issues
don't run the clean target when building all as we run into parallel races:
- memtest kicks off building of a bunch of .o files
- clean runs in parallel which runs `rm` and deletes some of the new .o
- memtest goes to link and fails because objects are missing
--- a/Makefile
+++ b/Makefile
@@ -19,7 +19,7 @@
smp.o vmem.o random.o
-all: clean memtest.bin memtest
+all: memtest.bin memtest
# Link it statically once so I know I don't have undefined
# symbols and then link it dynamically so I have full