You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/memtest86+/files/memtest86+-5.01-objcopy.patch

21 lines
654 B

Allow 'objcopy' override with user's OBJCOPY.
--- a/Makefile
+++ b/Makefile
@@ -8,6 +8,7 @@
# Path for the floppy disk device
#
FDISK=/dev/fd0
+OBJCOPY=objcopy
CFLAGS= -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin \
-ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
@@ -30,7 +31,7 @@ memtest_shared: $(OBJS) memtest_shared.lds Makefile
$(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
memtest_shared.bin: memtest_shared
- objcopy -O binary $< memtest_shared.bin
+ $(OBJCOPY) -O binary $< memtest_shared.bin
memtest: memtest_shared.bin memtest.lds
$(LD) -s -T memtest.lds -b binary memtest_shared.bin -o $@