You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ros/camera_calibration_parsers/files/boostpython.patch

21 lines
848 B

Revert special handling not needed on Gentoo.
https://bugs.gentoo.org/show_bug.cgi?id=608330
Index: camera_calibration_parsers/CMakeLists.txt
===================================================================
--- camera_calibration_parsers.orig/CMakeLists.txt
+++ camera_calibration_parsers/CMakeLists.txt
@@ -4,11 +4,7 @@ project(camera_calibration_parsers)
find_package(catkin REQUIRED sensor_msgs rosconsole roscpp roscpp_serialization)
find_package(PythonLibs REQUIRED)
-if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
- find_package(Boost REQUIRED COMPONENTS filesystem python)
-else()
- find_package(Boost REQUIRED COMPONENTS filesystem python3)
-endif()
+find_package(Boost REQUIRED COMPONENTS filesystem python)
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
catkin_python_setup()