You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/bcc/files/bcc-0.14.0-cmakelists.patch

20 lines
444 B

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65e78ffe..837b4939 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,14 +3,6 @@
cmake_minimum_required(VERSION 2.8.7)
project(bcc)
-if(NOT CMAKE_BUILD_TYPE)
- set(CMAKE_BUILD_TYPE Release)
-endif()
-
-if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
- set(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "path to install" FORCE)
-endif()
-
enable_testing()
# populate submodules (libbpf)