You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.7.0-a...

11 lines
503 B

--- a/amdocl/CMakeLists.txt 2020-08-23 10:11:28.227839351 +0200
+++ b/amdocl/CMakeLists.txt 2020-08-23 10:12:03.697839216 +0200
@@ -76,3 +76,7 @@
add_library(amdocl64 SHARED ${amdocl64_src})
target_link_libraries(amdocl64 amdrocclr_static Threads::Threads dl ${ADDITIONAL_LIBRARIES})
+
+file(GENERATE OUTPUT "${CMAKE_BINARY_DIR}/amdocl64.icd" CONTENT "$<TARGET_FILE_NAME:amdocl64>")
+install(FILES "${CMAKE_BINARY_DIR}/amdocl64.icd" DESTINATION "${CMAKE_INSTALL_FULL_SYSCONFDIR}/OpenCL/vendors/")
+