You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/nsgenbind/files/nsgenbind-0.1.1-glibc2.20.p...

18 lines
667 B

--- nsgenbind-0.1.1/Makefile
+++ nsgenbind-0.1.1/Makefile
@@ -16,13 +16,7 @@
WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
-Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
-Wmissing-declarations -Wnested-externs
-# BeOS/Haiku/AmigaOS have standard library errors that issue warnings.
-ifneq ($(TARGET),beos)
- ifneq ($(TARGET),amiga)
-# WARNFLAGS := $(WARNFLAGS) -Werror
- endif
-endif
-CFLAGS := -D_BSD_SOURCE -D_POSIX_C_SOURCE=200809L -I$(CURDIR)/include/ \
+CFLAGS := -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200809L -I$(CURDIR)/include/ \
-I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
ifneq ($(GCCVER),2)
CFLAGS := $(CFLAGS) -std=c99